Quantcast

Auto-Run feature in XP home....help!

manimal

Ociffer Tackleberry
Feb 27, 2002
7,214
14
Blindly running into cactus
i somehow, inadvertantly turned off the autorun pop-up thingy in xp. usually, when i pop a cd/dvd/flash drive in get a pop-up asking me what i want to do: open files, play media.......blah, blah, blah.

well, the other day i was playing around with something and turned it off and now i can't remember what i was playing around with.

any ideas on how to turn it back on? i know it was just a simple box that i clicked as an option but i have no idea where it was.
 

manimal

Ociffer Tackleberry
Feb 27, 2002
7,214
14
Blindly running into cactus
...also, if i put in a game, it used to automatically start up, now i have to manually go to it in programs to get it to play. it's like i have no auto-run even on .exe type of programs.
 

BrokenChain

Monkey
Oct 26, 2001
315
0
NWCT
Open My Computer. Right click on your CD drive and click Properties. Click the AutoPlay tab. Click the prompt me each time radio button. Click Apply, then OK. You should be good to go.
 

manimal

Ociffer Tackleberry
Feb 27, 2002
7,214
14
Blindly running into cactus
BrokenChain said:
Open My Computer. Right click on your CD drive and click Properties. Click the AutoPlay tab. Click the prompt me each time radio button. Click Apply, then OK. You should be good to go.
i just did all of that, even applied the setting for each different type of media but it still won't come up. my games still have to be started from the programs list. that's not the area i was messing around in when i screwed it up. does it require a restart maybe? i'll try that for now......
 

Changleen

Paranoid Member
Jan 9, 2004
9,900
5
Hypernormality
Bill hates you. You bought XP Cop edition right? It's known for it's inconsistant response to the same situation. It's a Karma thing. :D
 

binary visions

The voice of reason
Jun 13, 2002
21,695
498
NC
Try this:

1. Click Start, click Run, type regedit in the Open box, and then press ENTER.

2. Locate and click the following registry key (you can follow through the path just like it's a directory in Windows Explorer):
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom

3. To enable automatically running CD-ROMs, change the Autorun value to 1. To change a value, you right click on the item name (Autorun), click "Modify" and change the value.

4. Restart your computer.

If the Autorun value is already set at 1, then.. um, I'm not sure.
 

BikeGeek

BrewMonkey
Jul 2, 2001
4,424
72
Hershey, PA
binary visions said:
Try this:

1. Click Start, click Run, type regedit in the Open box, and then press ENTER.

2. Locate and click the following registry key (you can follow through the path just like it's a directory in Windows Explorer):
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom

3. To enable automatically running CD-ROMs, change the Autorun value to 1. To change a value, you right click on the item name (Autorun), click "Modify" and change the value.

4. Restart your computer.

If the Autorun value is already set at 1, then.. um, I'm not sure.
The pop-up he's asking about isn't unique to the CD drive. It comes up when you connect a camera or .mp3 player too.

Manimal: how'd you turn it off? I hate that thing.
 

manimal

Ociffer Tackleberry
Feb 27, 2002
7,214
14
Blindly running into cactus
BikeGeek said:
The pop-up he's asking about isn't unique to the CD drive. It comes up when you connect a camera or .mp3 player too.

Manimal: how'd you turn it off? I hate that thing.

correct.

i don't remember how i turned it off. i THINK it was in "sytem optimization" in my norton systemworks suite. but i can't find the same check box to turn it back on. everything in the drive properties shows that it should come up but it doesn't. it's nothing major but it saves me the step of actually navigating to the desired program/song/video/game.

i'm mainly just pissed because i have to go through -start-/programs.....to get to my games even after i insert the cd that should normally have a pop-up asking me if i want to play.
 

binary visions

The voice of reason
Jun 13, 2002
21,695
498
NC
BikeGeek said:
The pop-up he's asking about isn't unique to the CD drive. It comes up when you connect a camera or .mp3 player too.

Manimal: how'd you turn it off? I hate that thing.
Right, but he's complaining specifically about the CD-ROM. You could do a search in the "Services" directory for any keyword titled "Autorun" and switch them all one way or the other.

If you want to turn it off, set the Autoruns to 0 instead of 1.
 

manimal

Ociffer Tackleberry
Feb 27, 2002
7,214
14
Blindly running into cactus
binary visions said:
Right, but he's complaining specifically about the CD-ROM. You could do a search in the "Services" directory for any keyword titled "Autorun" and switch them all one way or the other.

If you want to turn it off, set the Autoruns to 0 instead of 1.
i did a help search for "autorun" and received the same instructions that brokenchain posted. i did it again, clicked apply for each type of media on all of the drives and it still won't work.
i pop a cd/dvd/flash drive in and nothing happens. i have to go in through my computer and open it manually.

wierd i tell you.
 

Pau11y

Turbo Monkey
Another place to check is msconfig. Look for anything that's not checked (your norton system works may have tweaked this a bit). I think what that popup is is a listening service and fires when any change related to storage has been detected on the system. I use a KVM at home w/ a Dell LCD that has a usb. When I switch back and forth from one machine to another, that popup comes up because I have a little MP3 player connected to the screen.

Edit: I was just messing around w/ the autoplay tab. It seems like it is in there as well. Go thru each file type and see if the radio button for select an action to perform is selected. If it is, you can hit Restore Defaults on each file type (drop down menu) and bring it back.
 

binary visions

The voice of reason
Jun 13, 2002
21,695
498
NC
I just turned off my auto play and turned it back on again. I don't understand why your system won't allow you to - all I did was what has already been suggested:

- Open My Computer
- Right click CD Drive
- Click Properties
- Select Auto Play tab
- For each item on the drop down list:
- Check the radio button "Select an action to perform"
- Click the button "Restore Defaults"
- Click OK

:think: It worked fine for me.

All I can think is that some registry setting is screwed up somewhere along the line and has disabled all auto play functions. If I get a minute today I'll do a little research on it.
 

manimal

Ociffer Tackleberry
Feb 27, 2002
7,214
14
Blindly running into cactus
binary visions said:
I just turned off my auto play and turned it back on again. I don't understand why your system won't allow you to - all I did was what has already been suggested:

- Open My Computer
- Right click CD Drive
- Click Properties
- Select Auto Play tab
- For each item on the drop down list:
- Check the radio button "Select an action to perform"
- Click the button "Restore Defaults"
- Click OK

:think: It worked fine for me.

All I can think is that some registry setting is screwed up somewhere along the line and has disabled all auto play functions. If I get a minute today I'll do a little research on it.
yeah, i've tried that several times now and the deafault is showing as being on. i think i used my norton system optimizer to change it and i can't find the tab to unchange it. stupid...stupid....stupid!
 

H8R

Cranky Pants
Nov 10, 2004
13,965
35
manimal said:
yeah, i've tried that several times now and the deafault is showing as being on. i think i used my norton system optimizer to change it and i can't find the tab to unchange it. stupid...stupid....stupid!
Did you re-boot?