Quantcast

Elixir CR help...

Discussion in 'The Shop' started by JohnE, Jul 20, 2012.

  1. JohnE

    JohnE filthy rascist

    Rep/Likes:
    147 / 641
    Joined:
    May 13, 2005
    Messages:
    12,686
    Location:
    Front Range, dude...
    Back break on my Elixir CRs is dragging. Have adjusted the pads, centered the calipers, done everything short of changing out the fluid. They still drag. Took them into the LBS, and he said he coud find nothing wrong and suggested I wasnt getting the wheel in straight...worked for 10 minutes and started rubbign on the way home again. Other than a liberal dose of C4, anybody got any suggestions? Rotors are straight, new pads maybe?

    Bueller, Bueller...
     

    Please register to disable this ad.

  2. canadmos

    canadmos Mater Slayer

    Rep/Likes:
    236 / 4,423
    Joined:
    May 29, 2011
    Messages:
    9,005
    Location:
    Canaderp
    Too much fluid?

    Did you bleed them with worn out pads before, and then put new ones in?
     
  3. IH8Rice

    IH8Rice I'm Mr. Negative! I Fail!

    Rep/Likes:
    62 / 485
    Joined:
    Aug 2, 2008
    Messages:
    24,856
    Location:
    Im over here now
    try pushing the pistons back in and bleed them with the bleed block in place
     
  4. JohnE

    JohnE filthy rascist

    Rep/Likes:
    147 / 641
    Joined:
    May 13, 2005
    Messages:
    12,686
    Location:
    Front Range, dude...
    Pushed the pistons in already, didnt want to bleed them, but if I have to...stand by for further.
     
  5. Capricorn

    Capricorn Monkey

    Rep/Likes:
    0 / 0
    Joined:
    Jan 9, 2010
    Messages:
    427
    Location:
    Cape Town, ZA
    brake rotor completely flat?
     
  6. JohnE

    JohnE filthy rascist

    Rep/Likes:
    147 / 641
    Joined:
    May 13, 2005
    Messages:
    12,686
    Location:
    Front Range, dude...
    As far as I can tell...going to take it off and check.