Quantcast

problems with pike lower legs and new casting anyone any info?

vitox

Turbo Monkey
Sep 23, 2001
2,939
1
Santiago du Chili
a few of my friends have broken their pikes at the lower part of the arch and i havent gotten any news from RS about a recall, but today i got this pic from one of my friends who broke one and clearly there are two different lower castings.

just wondering if anyone had had this problem or knew about it, or if there has been any official info from RS regarding it.

 

jake133

Monkey
Jan 21, 2005
373
0
SLC, Utah
yup my friend broke his in the exact same place maybe a bit higher. they sent him a new lowers. i have a pike and mine is fine but i am kinda nervious. its funny my broke the blue one as well. maybe its just the blue ones ahahah
 

Alex966

Monkey
May 6, 2005
347
0
Charlotte, NC
jake133 said:
yup my friend broke his in the exact same place maybe a bit higher. they sent him a new lowers. i have a pike and mine is fine but i am kinda nervious. its funny my broke the blue one as well. maybe its just the blue ones ahahah
Well unfortunately I'm that guy Lovebunny was referring too and Blue Pikes aren't the only one's breaking.
I broke a Pike Team, the black one, in the same exact area but on the left side of the arch. I wasn't even riding hard on it that day. It was at the Cal State DH chamionship. But if you've ever seen Fontana, where the race is held at, it's not really a true downhill, it's just a lot of loose switchbacks that head downhill and a few rock garden's and a couple small easy drop's.
 

snowskilz

xblue attacked piggy won
May 15, 2004
615
0
rado
I have seen a few break. My buddy kevins was most recent and RS has been good to all the ppl. Replacing the lowers at no cost. Just shipping if necessary(we live in Co so its just gas money for us)
 

monkeyboy424

Turbo Monkey
Mar 19, 2002
1,484
0
Place
i have had a different problem with my pike...

at a race, my front brake deciided to stop working, so i took it off and when i went to take it off, parts of magnesium came off with the bolts....

it is whack, and i already called RS and the rep said he could probably warrenty it.

any one else have this problem?