Quantcast

Saint cranks creaking

Slater

Monkey
Oct 10, 2007
378
0
Brand new cranks.
BB cups are tight.
Its not the pedals, does it with two different pairs.
Chingring and bash guard have been removed, cleaned and put back on with no luck
Its only in the drive side pedal that I feel it.

What gives?

Thanks guys!
 

Slater

Monkey
Oct 10, 2007
378
0
Tap which threads? All the threads are perfect.

Stef, I preload them enough so that they don't spin when I'm hiking. I can set the cranks level and they stay that way.

I previously had a set of XT's on this bike. I've done everything the same as with those, but have this creak for some reason.

How much grease should be on the spindle? There isn't much except for on the splines.

Thanks!
 

Arkayne

I come bearing GIFs
May 10, 2005
3,742
13
SoCal
Disassemble, apply a thin layer of grease on all mating surfaces, including your chainring bolts, and then wipe it all off clean. Reinstall and report back plskthx.
 

Slater

Monkey
Oct 10, 2007
378
0
Greased mating surfaces.
Changed chainrings to make sure it wasn't that.
Now after a full day of riding it has progressed to a "ticking" that I can hear and feel in the drive side pedal.
I'm out of ideas.
This sucks.
Especially since my riding buddy bought a set at the same time, put them on the same bike and they're perfect.

Other ideas gents?
 

ATOMICFIREBALL

DISARMED IN A BATTLE OF WITS
May 26, 2004
1,354
0
Tennessee
Greased mating surfaces.
Changed chainrings to make sure it wasn't that.
Now after a full day of riding it has progressed to a "ticking" that I can hear and feel in the drive side pedal.
I'm out of ideas.
This sucks.
Especially since my riding buddy bought a set at the same time, put them on the same bike and they're perfect.

Other ideas gents?
Maybe it's your frame? or seatpost ?.
Process of elimination takes time. Annoying sounds really suck!
 

Slater

Monkey
Oct 10, 2007
378
0
I guess I'll throw the XT's from my hardtail on it tomorrow and see what happens.

All testing has been done standing up, not on the seat.
And what gets me is that I only feel it in the drive side pedal, not both.
 

NJHCx4xLIFE

Monkey
Jan 23, 2007
350
0
Central Jersey
Check your chainguide too. I had the exact same problem with my saints and an Lg-1. I switched to a gamut and the noise went away. Just throwing out my personal experience.
 

Slater

Monkey
Oct 10, 2007
378
0
So its gone momentarily. I'll see if it resurfaces this weekend. I took out one spacer behind my backing plate for my chainguide.

However, the only reason I had to do this is because one of the 4 spider arms is bent. So I'll be sending them in for warranty. Don't know how they made it out of the factory like this but they did.

Thanks for all the help guys.