Quantcast

ubuntu 8.10 (intrepid ibex) wireless issues

$tinkle

Expert on blowing
Feb 12, 2003
14,591
5
for one, i lost the ability to see - and therefore connect to - available networks when i updated (i was piggybacking to configure), and now i can no longer connect to my hidden (ssid not broadcast) network. iwlist ath0 scan still shows available networks; just don't have a gui way to see them.

from this list of supported wireless cards, it appears mine ( Atheros AR5001X+) is unsupported. it seems i should just add this card's info to a config file & bounce.

also, having no luck w/ ndiswrapper install (but i think it's part of 8.10, so wtf am i doing dicking around w/ it?)

this was working b4 i installed patches/upgraded to 8.10 :rant:

ed: 5 min later & it works - AND I DO NOT KNOW WHY all i know is i did System -> Administration -> Hardware Drivers (wireless pci card only available option here): Deactivate; Activate

dubya-tea-effh?

i'll leave this thread here as a bookmark for eventual searching of this forum
 
Last edited:

$tinkle

Expert on blowing
Feb 12, 2003
14,591
5
also, does not connect to router automagically, even though "connect automatically" is checked.

does it need a keyring to be pushed, or some other manner of unlocking?
 

syadasti

i heart mac
Apr 15, 2002
12,721
290
VT
When I installed 8.10 from scratch I had to download the three packages on another computer (since I had no connection) and install them via USB key:

https://help.ubuntu.com/community/WifiDocs/Driver/Ndiswrapper

I have an rt2860 802.11n card (of course n doesn't work in ubuntu, just g) which does not have native drivers, I use the windows drivers.

We should have stuck with 8.04/LTS releases.

Hopefully they fix the shutdown issue - that is major PITA, physically hitting the reset or power button sucks.
 
Last edited:

syadasti

i heart mac
Apr 15, 2002
12,721
290
VT
I got off my ass and used teh google.

Stupid knuckleheads at ubuntu didn't bother to address this significant problem before release, people have known for awhile.

https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/274995

Here are two workarounds:

Quickfix:
ALT+sysrq+R (get keyboard control)
ALT+sysrq+E (kill tasks)
CTRL+ALT+DEL (call shutdown)

Better fix:
sudo gedit /etc/init.d/alsa-utils

The file opens in Gedit and around the line 353 you'll find the instruction "stop)" (or do a find for "stop)" (without quotes)). Below this instruction you should add these two instructions:

ifconfig wlan0 down
ifconfig eth0 down

So, the section of the file should look like this after editing (don't delete/change anything after this section!):

stop)
ifconfig wlan0 down
ifconfig eth0 down
EXITSTATUS=0

Best fix:
Don't release buggy software. Hopefully they push an update via update manager.
 

$tinkle

Expert on blowing
Feb 12, 2003
14,591
5
interestingly enough, this is related to a separate issue i'm having on my nettop box, which arbitrarily doesn't behave after the "HAL Daemon [OK]" line; x fails to clean up

even thought ubuntu (or other linux flavors) are viewed as more archane than either mac or 'doze, there's a lot more support from developers in realtime, which to me makes it more maintainable. apart from the fact that it's compatible w/ lots of M$ stuff.

the free part is nice, too
 

skatetokil

Turbo Monkey
Jan 2, 2005
2,384
0
DC/Bluemont VA
I'm running this on my main machine now, and it does seem like they've been pushing out an unusually\ large number of bug fixes and updates. Having no experience with ubuntu before it's hard to say if this is normal or not, but I've been getting batches of 8-10 files every few days.
 

$tinkle

Expert on blowing
Feb 12, 2003
14,591
5
i just applied 7 patches 5 min ago.

it now seems to automatically find my preferred AP, which is nice.

so, as JBP wrote: ubuntu is now curing all my ills (but i'm not an ubuntbot)
 

nomadewolf

Chimp
Mar 31, 2009
2
0
I got off my ass and used teh google.

Stupid knuckleheads at ubuntu didn't bother to address this significant problem before release, people have known for awhile.

https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/274995

Here are two workarounds:

Quickfix:
ALT+sysrq+R (get keyboard control)
ALT+sysrq+E (kill tasks)
CTRL+ALT+DEL (call shutdown)

Better fix:
sudo gedit /etc/init.d/alsa-utils

The file opens in Gedit and around the line 353 you'll find the instruction "stop)" (or do a find for "stop)" (without quotes)). Below this instruction you should add these two instructions:

ifconfig wlan0 down
ifconfig eth0 down

So, the section of the file should look like this after editing (don't delete/change anything after this section!):

stop)
ifconfig wlan0 down
ifconfig eth0 down
EXITSTATUS=0

Best fix:
Don't release buggy software. Hopefully they push an update via update manager.
Hey, i'm using openSUSE 11.1 64 bit, and i have EXACTLY the same problem.
But my system doesn't seem to have the /etc/init.d/alsa-utils file...
Wouldn't you happen to know how i do that on SUSE, would you?

Many thanks
 

nomadewolf

Chimp
Mar 31, 2009
2
0
Thanks anyway.
I've posted your solution in some SUSE forums (quoted, of course), to see if anyone knows where to make the equivalent changes in SUSE. Hope you don't mind...

Meanwile i've searched the entire file system for that file, but couldn't find it... Then i tried to search for the matching text within the files, but still no luck... SUSE must be quite different.

I'll post results, if i get them...
 
Last edited:

syadasti

i heart mac
Apr 15, 2002
12,721
290
VT
Installed 9.04 JJ yesterday. First attempt I installed the x64 version worked fine but then I realized important things like flash do not have an x64 version yet. Also realized I accidentally downloaded the alternative install CD which is text based.

Next I downloaded the regular 386 and installed it. Everything was fine but the wifi connection seemed slow and I thought maybe the new native drivers for my wifi card were the cause so I installed ndiswrapper and figured out things like system update were really slow because JJ just came out. Could not figure out how to remove ndiswrapper and switch back to the native driver as it worked slightly better so I just reinstalled a third time. Can't say I notice any huge improvement other than native rt2860 drivers and some small gui changes:

 

stringcheese

Monkey
Jun 6, 2002
360
0
Golden, CO
Thanks anyway.
I've posted your solution in some SUSE forums (quoted, of course), to see if anyone knows where to make the equivalent changes in SUSE. Hope you don't mind...

Meanwile i've searched the entire file system for that file, but couldn't find it... Then i tried to search for the matching text within the files, but still no luck... SUSE must be quite different.

I'll post results, if i get them...

Go into BIOS and turn off your onboard (motherboard) network adapter, then restart the computer. There's a hardware conflict going on and its probably recognizing your onboard adapter as the default one. If that doesn't work you might wanna google how to restart the driver manually.

I had to turn off my onboard networking and sound adapters so that my pci stuff worked properly in ubuntu (linux mint 6).


BTW- flash works fine in x64 using Samba.
 

syadasti

i heart mac
Apr 15, 2002
12,721
290
VT
I think Flash 11 will have official support beside the fact x64 gives minimal benefits for my needs. Maybe in a few years the situation will change but until compliers/libraries/etc mature its not really worthwhile for most.
 
Last edited: